NIX_System_Configurations/flake.nix
2023-12-21 21:48:41 +01:00

77 lines
2.1 KiB
Nix

{
description = "A very basic flake";
inputs = {
# import nixos packages
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
customnixpkgs.url = "github:lukas-heiligenbrunner/nixpkgs/resources-init";
# import homemanager
home-manager.url = "github:nix-community/home-manager";
home-manager.inputs.nixpkgs.follows = "nixpkgs";
nixos-hardware.url = "github:NixOS/nixos-hardware/master";
};
outputs = { self, nixpkgs, home-manager, nixos-hardware, customnixpkgs }:
let
system="x86_64-linux";
pkgs = import nixpkgs {
inherit system;
config.allowUnfree = true;
};
custompkgs = import customnixpkgs {
inherit system;
config.allowUnfree = true;
};
lib = nixpkgs.lib;
in {
nixosConfigurations = {
laptop = lib.nixosSystem {
inherit system;
specialArgs = { inherit custompkgs; };
modules = [
nixos-hardware.nixosModules.framework-13-7040-amd
./common/configuration.nix
./laptop/configuration.nix
home-manager.nixosModules.home-manager {
home-manager.useGlobalPkgs = true;
home-manager.useUserPackages = true;
home-manager.users.lukas = {
imports = [ ./common/home.nix ];
};
home-manager.users.root = {
imports = [ ./common/home-root.nix ];
};
}
];
};
exampleIso = nixpkgs.lib.nixosSystem {
system = "x86_64-linux";
specialArgs = { inherit custompkgs; };
modules = [
"${nixpkgs}/nixos/modules/installer/cd-dvd/installation-cd-graphical-calamares.nix"
./common/configuration.nix
home-manager.nixosModules.home-manager {
home-manager.useGlobalPkgs = true;
home-manager.useUserPackages = true;
home-manager.users.lukas = {
imports = [ ./common/home.nix ];
};
home-manager.users.root = {
imports = [ ./common/home-root.nix ];
};
}
];
};
};
};
}